Element 14 videos not playing.

Want to just shoot the breeze? Forum 42 is the place!

Moderator: Moderators

Post Reply
User avatar
Hifeno
Portablizer Extraordinaire
Posts: 666
Joined: Sat Jul 19, 2008 4:12 pm
Location: Seneca SC
Contact:

Element 14 videos not playing.

Post by Hifeno » Wed Dec 08, 2010 7:45 pm

I went to element 14 to watch the newest episode of Ben Heck show and the video doesn't load in fact none of the past ones load either. I also tried to go the the revision 3 website to watch and it does not load. Anyone know why this is I tried IE, FF, and GC not working on any.
That's Hacking Awsome
Image
Visit my Website http://hifeno.webs.com/" onclick="window.open(this.href);return false;

User avatar
khaag
Senior Member
Posts: 2260
Joined: Sat Mar 18, 2006 7:54 pm
Location: C eh N eh D eh
Contact:

Re: Element 14 videos not playing.

Post by khaag » Wed Dec 08, 2010 9:45 pm

I've had to watch it directly off of Revision3. Element 14 doesn't work for me either...

Haunted360
Posts: 1000
Joined: Sat Jan 30, 2010 12:22 am
PSN Username: Haunted360
360 GamerTag: Haunted 360
Location: Australia
Contact:

Re: Element 14 videos not playing.

Post by Haunted360 » Thu Dec 09, 2010 6:21 am

The servers are busy...

Ben Heck is just too damn popular these days with Nintendos, and fairyfloss...

User avatar
Hifeno
Portablizer Extraordinaire
Posts: 666
Joined: Sat Jul 19, 2008 4:12 pm
Location: Seneca SC
Contact:

Re: Element 14 videos not playing.

Post by Hifeno » Fri Dec 10, 2010 1:50 pm

I can not get on revision 3 it comes up site down.
That's Hacking Awsome
Image
Visit my Website http://hifeno.webs.com/" onclick="window.open(this.href);return false;

Post Reply