2010 Post Your Ride thread! 56k beware!

Want to just shoot the breeze? Forum 42 is the place!

Moderator: Moderators

Post Reply
User avatar
Triton
Moderator
Posts: 7396
Joined: Mon May 24, 2004 12:33 pm
360 GamerTag: triton199
Steam ID: triton199
Location: Iowa
Contact:

2010 Post Your Ride thread! 56k beware!

Post by Triton » Tue Apr 13, 2010 7:01 pm

Whether it be a car, truck, suv, minivan, bike, scooter, motorcycle or ANY other means of conveyance post them here! tell us a little about what moves you! :lol:

Here are some really big pictures of my new car! its a 1987 VW cabriolet wolfsburg edition and it is the color combo called triple white (white body, interior and top)
Image

User avatar
bicostp
Moderator
Posts: 10491
Joined: Mon Mar 07, 2005 5:47 pm
Steam ID: bicostp
Location: Spamalot
Contact:

Re: 2010 Post Your Ride thread! 56k beware!

Post by bicostp » Tue Apr 13, 2010 9:44 pm

I can't believe you still have the Jimmy you rolled 4 years ago... :shock:

Whose LeBaron is that? Was it you who had that 50s Oldsmobile with a small block Chevy, and if so do you still have it? Why'd you get rid of the Lolvo?

I drive one of these:

Image

Not a picture of my exact car, but it's completely identical with a few differences:

- The car in the picture probably doesn't have a redneck-installed aftermarket stereo. It was originally a botched home install from the previous owners, and it rattled all the time. (Hell, the whole dash rattled.) Took it all apart and redid it properly. (I lucked out; they used a breakout cable for the factory stereo connector and didn't cut the dash harness.)
- Mine got punched in the nose at one point, so it's got a little cosmetic damage to the front bumper cover and the hood has some orange peel.
- I repainted the front and rear bumpers semigloss black because they were faded, and repainted the stock wheel covers with Duplicolor silver wheel paint. (Not riced-out Wal-Mart fake chrome metallic, they look stock from a distance. They were just getting pitted and the original paint was coming off after years of brake dust removal.)
- I replaced all the brake hydraulics (except the master cylinder and hardline) after my front passenger side caliper failed and cooked the oil, leaving me with no brakes in a parking lot.

Yes it's a sedan (more doors = more whores :mrgreen:), but it still gets 34 MPG highway on cheap gas. Plus it's almost completely made of plastic, and all the frame metal was undercoated a couple times at the factory. Great for the rust belt. :lol: 86k miles.

Long-winded, semi-offtopic project ramble/wishful thinking:
Spoiler:
We've also got one of these kicking around:

Image
(Except it's dark orange, not Granny Green.)

1974 D200, 225 Slant Six, 3/4 ton, 8' bed, 4 speed manual (1st gear is almost a crawler), 4.1:1 Dayna 60 in the rear, Roadmaster AM/FM stereo cassette. Two new rear tires, but it needs a lot of work, as it hasn't been on the road in almost 21 years:
- Both the driver and passenger side floors are very rotten, some really big holes
- Rear brakes haven't worked since before Clinton took office
- Wheel arches and rear portions of front fenders are rusty/patched
- Exhaust gasket needs to be replaced; you can feel exhaust beat out from around it on the back cylinder
- Miscellaneous electrical issues, mostly "clean the corrosion off, blow on it, reassemble, hope the power light doesn't blink" type fixes.
- Mice love the seat and heater box
- Weatherstripping is basically shot due to exposure
- The passenger side is pretty thrashed. Our theory is it slid into a tree at some point. There's no passenger side mirror, the whole door skin is mangled (basically the door isn't salvageable), the cab corner's bent up, and it has a 12" by 8" by 4" deep dent in the front of the bed.
- The bottom of the radiator core support is pretty much gone; there's a disturbing amount of big, rusted-off chunks of it sitting in the crossmember.

But despite all that it starts and runs like new every time, and we just used it to pull a couple trees down a couple weeks ago. 88k miles. I *really* want to do something with it, but money's an issue. (More specifically, a lack thereof.) So for now I try to maintain the status quo and do cheap fixes. (For example, sanding surface rust and hitting it with heavy rust primer, fixing electrical contacts, and experimenting with different secondhand light bulbs until I find a combination that completely works. (The glove box is full of random marker and tail lights that may or may not work.)

User avatar
marshallh
Moderator
Posts: 2986
Joined: Sat Sep 10, 2005 2:17 pm
360 GamerTag: marshallh
Location: here and there
Contact:

Re: 2010 Post Your Ride thread! 56k beware!

Post by marshallh » Tue Apr 13, 2010 10:39 pm

pretty much the same as last time. I will be doing a lot of maintenance this summer. Coilovers will really be the only thing noticeable (2-3" drop).

Image



Before (when I got it)
Image



After
Image
Image
Image

User avatar
collinE
Posts: 891
Joined: Thu Aug 07, 2008 9:07 am
Location: Salt Lake City, Utah
Contact:

Re: 2010 Post Your Ride thread! 56k beware!

Post by collinE » Tue Apr 13, 2010 10:54 pm

This may be in the "Show us yourself" thread, but this is my '08 Altima... also my '08 yorkie.

Image
It takes a big man to cry, but it takes a bigger man to laugh at that man.

Ridonkulous

User avatar
Triton
Moderator
Posts: 7396
Joined: Mon May 24, 2004 12:33 pm
360 GamerTag: triton199
Steam ID: triton199
Location: Iowa
Contact:

Re: 2010 Post Your Ride thread! 56k beware!

Post by Triton » Tue Apr 13, 2010 11:02 pm

bicostp wrote:I can't believe you still have the Jimmy you rolled 4 years ago... :shock:

Whose LeBaron is that? Was it you who had that 50s Oldsmobile with a small block Chevy, and if so do you still have it? Why'd you get rid of the Lolvo?
*yep still have the jimmy, AND if we fix the wiring to the fuel pump it will still run and drive, it was running about a year ago.
*the lebaron is my parents car, and what i was driving before the drivers axle broke, tis going to be fixed and painted this summer.
*still have the oldsmobile (1954 super 88 to be exact), it should be visible in the background of some of the pictures in that album., it needs a transmission but thats easy
*the lolvo was nice cosmetically but was starting to develop problems and cost me more money than i liked to keep it running so i sold it in may of 09. i miss it sometimes but then i remember how much of a pain in my ass it was :lol:

User avatar
vskid
Senior Member
Posts: 6314
Joined: Fri Mar 25, 2005 8:25 am
Steam ID: vskid3
Contact:

Re: 2010 Post Your Ride thread! 56k beware!

Post by vskid » Wed Apr 14, 2010 1:04 pm

Triton wrote:*still have the oldsmobile (1954 super 88 to be exact), it should be visible in the background of some of the pictures in that album., it needs a transmission but thats easy
Your link doesn't go to the album, it goes to a pic of the rear. :|

I currently have a 1990 Jeep Comanche, 4x4, 4l I6, 5 speed manual, ~6" of lift, 157,000 miles. Ugly as heck, sways like a drunk, and it rides like the axles are welded to the frame. It'll get up and move, though, lots of torque and weighs as much as a midsize car. I'm try to sell it because to make it into an offroad beast will cost a lot of moneys, something that I don't have. If anyone wants it, shoot me a PM. :wink:
Image

I'm thinking of getting a manual Ford Focus at the end of the year. Preferably a wagon, but I'll take any 4 door if the price is right.
Image

User avatar
Triton
Moderator
Posts: 7396
Joined: Mon May 24, 2004 12:33 pm
360 GamerTag: triton199
Steam ID: triton199
Location: Iowa
Contact:

Re: 2010 Post Your Ride thread! 56k beware!

Post by Triton » Wed Apr 14, 2010 10:44 pm

vskid wrote:
Triton wrote:*still have the oldsmobile (1954 super 88 to be exact), it should be visible in the background of some of the pictures in that album., it needs a transmission but thats easy
Your link doesn't go to the album, it goes to a pic of the rear. :|
fixd!

User avatar
limpport
Senior Member
Posts: 1873
Joined: Sun Jan 29, 2006 12:32 pm
Location: (the only person here from) Vermont
Contact:

Re: 2010 Post Your Ride thread! 56k beware!

Post by limpport » Thu Apr 15, 2010 10:26 am

Image
(^Not my car)

2001 (I think) Ford Windstar LX Sport. It has a spoiler!

Imagine this in black (and not crappy looking):
Image

The ride I hope to get for the summer:
Image
Trek 3700 Hardtail

User avatar
gamemasterAS
Senior Member
Posts: 3309
Joined: Thu Nov 24, 2005 10:30 pm
Steam ID: lolz1337face
Location: Ohio
Contact:

Re: 2010 Post Your Ride thread! 56k beware!

Post by gamemasterAS » Thu Apr 15, 2010 2:32 pm

I hoof it.
.

User avatar
schmellyfart
Portablizer Extraordinaire
Posts: 1150
Joined: Sun Mar 05, 2006 8:29 pm
Steam ID: schmellyfart
Location: Gilbert, AZ
Contact:

Re: 2010 Post Your Ride thread! 56k beware!

Post by schmellyfart » Sun Apr 18, 2010 4:33 am

Triton, what happened to that BMW you were working on?

Same grocery getter as last time, but with a couple more goodies that will improve my 0 - grocery store time by a couple seconds :lol:

Image
Image

User avatar
mako321
Posts: 711
Joined: Mon Aug 10, 2009 6:27 am

Re: 2010 Post Your Ride thread! 56k beware!

Post by mako321 » Sun Apr 18, 2010 9:07 am

I like your license plate.

User avatar
Triton
Moderator
Posts: 7396
Joined: Mon May 24, 2004 12:33 pm
360 GamerTag: triton199
Steam ID: triton199
Location: Iowa
Contact:

Re: 2010 Post Your Ride thread! 56k beware!

Post by Triton » Sun Apr 18, 2010 11:31 am

Triton, what happened to that BMW you were working on?
I sold it, turns out there was a LOT more wrong with it than i initially thought. i did a bit better than break even on it, so its alright lol

User avatar
Rekarp
Portablizer Extraordinaire
Posts: 2163
Joined: Thu Dec 28, 2006 1:52 am
PSN Username: Lnghrn_
Steam ID: rekarp
Location: Austin, Tx
Contact:

Re: 2010 Post Your Ride thread! 56k beware!

Post by Rekarp » Thu Apr 22, 2010 11:52 am

Really old picture.

Image
The wood master

Image

"I was under the impression Mac owners don't actually USE their machines, they just parade them around trying to evangelize the masses."

User avatar
Triton
Moderator
Posts: 7396
Joined: Mon May 24, 2004 12:33 pm
360 GamerTag: triton199
Steam ID: triton199
Location: Iowa
Contact:

Re: 2010 Post Your Ride thread! 56k beware!

Post by Triton » Sat Apr 24, 2010 6:23 pm

updated pic, still have more painting to do
Image

User avatar
DK
Posts: 1107
Joined: Fri Jun 30, 2006 4:00 am
Location: None of your business pedo nerds

Re: 2010 Post Your Ride thread! 56k beware!

Post by DK » Sun Apr 25, 2010 2:58 am

Image

2003 Type 2 Campervan:

1.6l Fuel injected engine
16 inch Porsche Alloys
Private plate
Cow fur roof lining
Slightly broken air horn that sounds like a cow mooing :mrgreen:
Image

Post Reply