Cart emulator progress thread

Includes but not limited to: SNES, Genesis, Sega CD, PlayStation 1, Nintendo 64, Dreamcast, Game Gear and I guess the Virtual Boy.

Moderator: Moderators

Post Reply
akuten
Posts: 3
Joined: Fri Oct 07, 2011 8:10 am

Re: Cart emulator progress thread

Post by akuten » Sun Feb 19, 2012 9:41 pm

marshallh wrote:
tdb wrote:I will also look into the save issues (which are probably related to the black screen)
Ah yeah, probably. The black screen on reset actually happened to the same save file, making me lose some progress not long prior to it failing entirely as mentioned earlier.

User avatar
sanni
Posts: 23
Joined: Wed Jul 14, 2010 5:52 am
Location: Germany
Contact:

Re: Cart emulator progress thread

Post by sanni » Mon Feb 20, 2012 7:16 am

Two suggestions:

- When selecting between Browse, Options and About the menu expects the analog stick to change from 0 to another state, some analog sticks don't reset back to 0 when you let them go making the selection a little hard. You should incorporate a little deadzone here.
- When selecting a game with the dpad you should only move up/down one game per pressed direction and not autoscroll

chunky
Posts: 13
Joined: Thu Aug 05, 2010 9:19 am

Re: Cart emulator progress thread

Post by chunky » Mon Feb 20, 2012 10:42 pm

marshallh wrote:Lots of new things/fixes in both menu 1.08 and firmware 1.03. Grab them both from the support page
Is there a guide to updating the firmware anywhere?

I assumed I'd just install the USB Drivers (FTDI D2XX) [CDM20814_Setup.exe], and then run The Easy Upgrade (1.03) [64drive_firm_103.exe]?

But that just gives me an error telling me that FTD2XX.dll is missing.

cyto
Posts: 3
Joined: Wed Feb 15, 2012 7:09 pm

Re: Cart emulator progress thread

Post by cyto » Mon Feb 20, 2012 11:52 pm

marshallh wrote:Lots of new things/fixes in both menu 1.08 and firmware 1.03. Grab them both from the support page
Any word on the surprise features you've been working on? How about cheat support?

It really works better than the PC emulators. I haven't seen any glitches with the ROMs themselves, only the saving black screen bug. Too bad there will not be a way for hi-res textures like the 128MB upgrade to the Xbox RAM. 4KB texture memory is just too small. No biggie, I've got a PC for those anyways but .cht support would be great. No way I'm going for the 120 stars in SM64 again. The reward was too small for so much time invested.

User avatar
Lady Eklipse
Posts: 30
Joined: Thu Feb 17, 2011 4:57 am

Re: Cart emulator progress thread

Post by Lady Eklipse » Tue Feb 21, 2012 1:05 am

Install the drivers from marshallh's website.
Find FTD2XX.dll via search (somewhere in Windows folder).
Place this file into the folder where your upgrader executable is situated.
It's weird, but that's how I could manage it.

User avatar
Disco_Stu
Posts: 11
Joined: Wed Feb 11, 2009 2:39 pm
Contact:

Re: Cart emulator progress thread

Post by Disco_Stu » Tue Feb 21, 2012 3:11 am

marshallh wrote:
tdb wrote:Ten days have past since my last post. Still no update on my order from Marshall, and I'm still waiting on a shipment notice. I've tried pm (on assembler forum), I've tried email; no respons. I guess he is too busy assembling all orders. An update on my situation would be much appreciated.
Yours is good to go, along with a bunch more people's orders I just shipped today. The exact dates are on the 64drive site.

The black screen on reset is something I fixed in the beta firmware, but I haven't had time to polish it up and get it released. Should see that, along with menu 1.08 out within the next week. I will also look into the save issues (which are probably related to the black screen)
I'm a little bit confused now. You've wrote on the 64drives purchase page that you've shipped PAL preorders until Oct 29. I've ordered my 64 drive on AUG 28 and I still didn't receive it, a shipping note nor a reply on my email...

Did something went wrong here?
Image

CyberAxe
Posts: 1
Joined: Wed Feb 22, 2012 4:57 am

Re: Cart emulator progress thread

Post by CyberAxe » Wed Feb 22, 2012 6:17 am

Disco_Stu wrote:
marshallh wrote:
tdb wrote:Ten days have past since my last post. Still no update on my order from Marshall, and I'm still waiting on a shipment notice. I've tried pm (on assembler forum), I've tried email; no respons. I guess he is too busy assembling all orders. An update on my situation would be much appreciated.
Yours is good to go, along with a bunch more people's orders I just shipped today. The exact dates are on the 64drive site.

The black screen on reset is something I fixed in the beta firmware, but I haven't had time to polish it up and get it released. Should see that, along with menu 1.08 out within the next week. I will also look into the save issues (which are probably related to the black screen)
I'm a little bit confused now. You've wrote on the 64drives purchase page that you've shipped PAL pre-orders until Oct 29. I've ordered my 64 drive on AUG 28 and I still didn't receive it, a shipping note nor a reply on my email...

Did something went wrong here?
I ordered mine on the 5th of October and got mine a week or so ago, I'm in the UK (though I ordered an NTSC one) I sent a couple of emails over the months just to make sure my order hadn't gotten lost.

Once yours is shipped you should get an email saying it has been shipped and a tracking number.

I initially thought it was buggy but realized it was just bad ROMs, now I just need to fix my reset button so I can save!, It would be nice if someone came out with a GB Flash cart that was compatible with the N64 Transfer Pak, as I'd like to use that properly and i hate relying on battery saves of my original carts when you have no idea when they are gonna fail.

Also to people worried about the price point I specifically waited and bought this over the everdrive 64 as the everdrive 64 doesn't play anywhere near as many games from what I'd read at the time, also on the everdrive you have to pay for firmware updates, and stuff so in the end you are getting a lot more from the 64drive than the everdrive.

User avatar
sevin0seven
Posts: 36
Joined: Wed Jul 07, 2010 6:44 pm
PSN Username: sevin0seven
360 GamerTag: sevin0seven
Steam ID: sevin0seven
Location: Bay Area, CA
Contact:

Re: Cart emulator progress thread

Post by sevin0seven » Tue Mar 13, 2012 9:36 pm

marshallh wrote:Lots of new things/fixes in both menu 1.08 and firmware 1.03. Grab them both from the support page
when i installed firmware 1.03, it still says 1.02 on the menu. :?:

love the new features on menu 1.08 though, keep it coming. thanks marshallh. :)

KyoufuNoDaio
Posts: 16
Joined: Thu Feb 24, 2011 3:25 pm

Re: Cart emulator progress thread

Post by KyoufuNoDaio » Thu Mar 15, 2012 8:39 pm

sevin0seven wrote:
marshallh wrote:Lots of new things/fixes in both menu 1.08 and firmware 1.03. Grab them both from the support page
when i installed firmware 1.03, it still says 1.02 on the menu. :?:

love the new features on menu 1.08 though, keep it coming. thanks marshallh. :)
Same happened to me. I just updated again and it worked fine.

eggwolio
Posts: 11
Joined: Thu Feb 09, 2012 11:48 pm
PSN Username: chupdong
360 GamerTag: eggwolio
Steam ID: eggwolio

Re: Cart emulator progress thread

Post by eggwolio » Tue Mar 20, 2012 12:08 am

I ordered mine at the end of February and I'm going insane with the waiting. How were all of you so patient?! I'm so excited to get this thing. Also, has anyone done a tutorial on putting in the 6105? I've sent two emails to marshall, but he's a busy man these days, so it's understandable that I haven't heard back. I'm not great at soldering, but my ladyfriend is pretty alright at it, so I doubt we'll have much trouble with installing the chip, but I just wanna be prepared when it arrives. Thanks!

Sent from my SAMSUNG-SGH-I927 using Tapatalk

User avatar
marshallh
Moderator
Posts: 2986
Joined: Sat Sep 10, 2005 2:17 pm
360 GamerTag: marshallh
Location: here and there
Contact:

Re: Cart emulator progress thread

Post by marshallh » Tue Mar 20, 2012 12:51 am

Solder in the 6105, pin 1 faces down matching the silkscreen. Then jump the two pads labeled BANK next to it.
Image

eggwolio
Posts: 11
Joined: Thu Feb 09, 2012 11:48 pm
PSN Username: chupdong
360 GamerTag: eggwolio
Steam ID: eggwolio

Re: Cart emulator progress thread

Post by eggwolio » Tue Mar 20, 2012 1:19 am

Thanks for your reply, marshall. Could I send you a donor cart for it or is that not something you offer? I totally understand you have a bajillion cart orders and doing custom stuff like this may not be possible, but I figured it's worth asking. Really looking forward to the progress of your vga mod, too.

Sent from my SAMSUNG-SGH-I927 using Tapatalk

User avatar
marshallh
Moderator
Posts: 2986
Joined: Sat Sep 10, 2005 2:17 pm
360 GamerTag: marshallh
Location: here and there
Contact:

Re: Cart emulator progress thread

Post by marshallh » Tue Mar 20, 2012 3:08 am

I will have a look at my pcb stash later on. I know I have gotten a few Perfect Dark carts in the past couple months.
Image

User avatar
marshallh
Moderator
Posts: 2986
Joined: Sat Sep 10, 2005 2:17 pm
360 GamerTag: marshallh
Location: here and there
Contact:

Re: Cart emulator progress thread

Post by marshallh » Tue Mar 20, 2012 3:16 am

Also, firmware 1.04 is out, for anybody that was having problems with CF introduced in the last update.

The cart is designed to not brick itself and there are several failsafes that prevent this. I tweaked the timing in the 1.04 easy updater so it should be not triggering these mechanisms any more. Worst case, you have your old firmware, and you just run the updater again. I haven't been able to duplicate this on my own machine so I will have to play around some more.
Image

baconpork
Posts: 2
Joined: Sun Jan 15, 2012 2:47 pm
360 GamerTag: baconpork

Re: Cart emulator progress thread

Post by baconpork » Sat Mar 31, 2012 2:33 pm

I have had my 64drive for about a month or so and it has been working fine until about three days ago. When I turned on my N64, I got the a message about no memory card being found. Since then, when I power up the 64drive, nothing happens most of the time (as in screen stays black), however, I occasionally get the message "No bus response." What should I do? I don't believe that I have done anything out of the ordinary that would have caused this error.

Post Reply