Is this normal???

Includes but not limited to: SNES, Genesis, Sega CD, PlayStation 1, Nintendo 64, Dreamcast, Game Gear and I guess the Virtual Boy.

Moderator: Moderators

Post Reply
ma70delgado
Posts: 3
Joined: Wed Jun 23, 2010 1:45 pm

Is this normal???

Post by ma70delgado » Wed Jun 23, 2010 1:53 pm

i bought a snes and it was like this it works perfectly but i wanna see if snes are like that or should i fix it right away

http://www.youtube.com/watch?v=793dWgwpYQI" onclick="window.open(this.href);return false;

User avatar
Metallica Man X
Portablizer Extraordinaire
Posts: 1437
Joined: Fri Apr 22, 2005 1:14 pm
Location: A very anti-metal place...WI...
Contact:

Re: Is this normal???

Post by Metallica Man X » Wed Jun 23, 2010 6:26 pm

It's not supposed to be that way, but it works. My youngest bro has a SNES with the plug that way as well. It used to have a plug in there, but it fell out. It shouldn't be too much trouble, tho after a while it might get hard to keep the power on with the plug that way. But, it is pretty easy to fix.
Image
The answer to 1984 is 1776!
"One of the penalties for refusing to participate in politics is that you end up being governed by your inferiors." - Plato

ma70delgado
Posts: 3
Joined: Wed Jun 23, 2010 1:45 pm

Re: Is this normal???

Post by ma70delgado » Wed Jun 23, 2010 8:48 pm

sorry but my graphics are messed up is this the problem?

Image

User avatar
stuntpenguin007
Posts: 667
Joined: Sun Apr 27, 2008 12:21 pm

Re: Is this normal???

Post by stuntpenguin007 » Wed Jun 23, 2010 10:56 pm

are you talking about the missing pins in the cartridge slot? That's normal.
SNESP WIP
Case - 50%
acquired parts - 90%
assembly - 0%

ma70delgado
Posts: 3
Joined: Wed Jun 23, 2010 1:45 pm

Re: Is this normal???

Post by ma70delgado » Wed Jun 23, 2010 11:57 pm

no you see the last pin on the top right it looks strange?

User avatar
metalcookie
Posts: 393
Joined: Sat Mar 21, 2009 12:29 pm
Location: Walter Sullivan's apartment

Re: Is this normal???

Post by metalcookie » Fri Jun 25, 2010 12:19 am

It looks a little bent, but I don't think it'll be a problem. And as for the power issue, all I did to fix it is pull the power cord tight up against one of the sides and duck tape it to get it to stay. WD-40 and duck tape fixes everything. 8)
Some guy wrote:If it moves and it shouldn't, use duck tape. If it doesn't move and it should, use WD-40.
Citizen Kane

Post Reply