Some sound issues on my 2600 portable

Do you have a technical question that doesn't really fit a specific console? Want some general info on electronics, hacking, making cookies, etc? Here's the place to ask! Go nuts.

Moderator: Moderators

Post Reply
thomas3120
Posts: 2
Joined: Mon Sep 26, 2011 3:49 pm

Some sound issues on my 2600 portable

Post by thomas3120 » Wed Jul 25, 2012 4:36 am

Hello,
Just finishing up my 'Atari Gear' 2600 portable. Here's a pic and also a video:
Image
*Need to polish the clear lense a bit more...

Video:
http://www.youtube.com/watch?v=3WjdU4ar1BU" onclick="window.open(this.href);return false;

Made from a light sixer I had around. I also did the LongHornEngineer's video mod (only composite out for small LCD).
Most all games sound great. Getting audio from pins 12 & 13 from TIA chip, then amplifying to a small speaker or headphone jack.
I'm using the TDA7052A audio amplifier IC.
Getting really good clear results with Pressure Cooker (has some good tunes in the game) as well as most others.
Some games like Pitfall II sound really distorted and the screen jumps every once in a while (only this game). I know Pitfall II has some sort of 'upgraded' sound (IC?) in the cart.
Also the game Asteroids sounds a bit distorted when firing (not quite right..)
But most all other games sound really good.
Wondering, if this is happening because the sound isn't going through/mixed in the CD4050 IC...?

Any suggestions, ideas would be greatly appreciated.

thomas
My Youtube channel thomas3120

Post Reply