Willem Programmer not reading EPROM correctly

Do you have a technical question that doesn't really fit a specific console? Want some general info on electronics, hacking, making cookies, etc? Here's the place to ask! Go nuts.

Moderator: Moderators

Post Reply
User avatar
Creebo
Posts: 59
Joined: Wed Mar 19, 2008 3:57 pm
360 GamerTag: TheWillToHarp
Steam ID: FireflyTi
Location: Milwaukee, Wisconsin
Contact:

Willem Programmer not reading EPROM correctly

Post by Creebo » Thu Apr 19, 2012 6:23 pm

I just got my EPROM eraser today after a long three weeks, so I figured I could start using some EPROMs for projects. Well I went to test my programmer by throwing a EPROM in it that I took off of a MAME board. I did a read on it, and instead of what I thought would look like data (this is from a main game EPROM) is just a bunch of lines of either 00 or 10.

So I thought, okay, well I'll erase a chip and see what happens. So I stick one in the toaster for 15 minutes or so and then I do a read, but I get nothing but 90 repeated. I'm assuming the programmer isn't reading it right.

I've tried about 8 EPROMs, half of the are 27c512's and the others are 27c010. I know all of them worked less than 6 months ago. If anyone had some insight, I'd love to hear it!

Post Reply