Battery Hum

Do you have a technical question that doesn't really fit a specific console? Want some general info on electronics, hacking, making cookies, etc? Here's the place to ask! Go nuts.

Moderator: Moderators

Post Reply
User avatar
The Earl of Sandwich
Posts: 52
Joined: Mon Jun 26, 2006 2:32 am
Location: Idaho
Contact:

Battery Hum

Post by The Earl of Sandwich » Tue Oct 31, 2006 10:27 pm

I'm still working on my NESp (albeit very slowly), and recently wired it so my battery and power supply can be connected at the same time. When they are both connected, I get a hum through the audio channel.
If it matters, the battery is a NI-MH
Any Ideas why it does this or how one might fix it?

User avatar
CronoTriggerfan
Moderator
Posts: 4131
Joined: Fri Jan 27, 2006 3:07 pm
Location: University of Michigan - Ann Arbor
Contact:

Post by CronoTriggerfan » Tue Oct 31, 2006 11:45 pm

A bit more info, please! Is the battery you have at the proper operating voltage, and do you have enough amperage to power the system?

CTFan
Image

User avatar
timmeh87
Senior Member
Posts: 3047
Joined: Mon Nov 14, 2005 10:19 pm
Location: Ontario, Canada

Post by timmeh87 » Wed Nov 01, 2006 1:12 am

so you only get the hum when the power adapter is connected?

is it just an AC wall adapter? if so, its probably really noisy. try putting a big cap on it.
Image

"Linux is only free if your time is worthless"

User avatar
The Earl of Sandwich
Posts: 52
Joined: Mon Jun 26, 2006 2:32 am
Location: Idaho
Contact:

Post by The Earl of Sandwich » Wed Nov 01, 2006 9:37 am

@CTFan- Yes, it's at the right voltage, and it appears that I have enough amperage (the system works)

@timmeh- Where would I put the cap?

User avatar
timmeh87
Senior Member
Posts: 3047
Joined: Mon Nov 14, 2005 10:19 pm
Location: Ontario, Canada

Post by timmeh87 » Wed Nov 01, 2006 7:37 pm

across the input. like:

Code: Select all

-------
|     |==
| AC  |
|ADAP.|
-------
||
||
| \
|  \
|   \
|    |
|+   |-
|    |
|-|(-| <- thats a capacitor
|    |
|    |
v    v
(to system)
try something like 100uF - 1000uF electrolytic or 10uF - 100uF tantalum to start. careful, they are direction-sensitive (backwards = explosion)
Image

"Linux is only free if your time is worthless"

User avatar
The Earl of Sandwich
Posts: 52
Joined: Mon Jun 26, 2006 2:32 am
Location: Idaho
Contact:

Post by The Earl of Sandwich » Sat Nov 04, 2006 8:42 pm

I scrounged a 10uF cap from a NES quickshot controller, wired it up as follows:
Image
and I still get the hum. Do I need a bigger cap?

User avatar
timmeh87
Senior Member
Posts: 3047
Joined: Mon Nov 14, 2005 10:19 pm
Location: Ontario, Canada

Post by timmeh87 » Sat Nov 04, 2006 11:02 pm

hm well im not 100% sure that that is your problem.

still, 10uf electrolytic (as it probably is) might be a bit low to take care of the kind if ripple you might be dealing with.

keep the 10uf one there, and try to find a 100+uf one to put in parallel with it. reason is that the ESR on big caps might be a bit high to handle higher frequencies, but the capacitance of small caps might be too low to smooth it out. so you kinda get both working together.

sorry if i explaned that bad, i dont have a very firm grasp on the knowledge myself. someone like codeman could probably clear it up a bit.
Image

"Linux is only free if your time is worthless"

Post Reply